cve.bz

CVE-2026-48717

9.1 criticalEPSS 0.5%

Critical (9.1). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in org.openidentityplatform.openam:openam-oauth2 16.1.1.

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.

Severity

CVSS 4.0

9.1 critical
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-285
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4v2w-2wqp-mc85Mavenorg.openidentityplatform.openam:openam-oauth2<16.1.116.1.1

References

Check your stackJSON