CVE-2026-48156
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.0, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W [0 0 0] values and large /Size values. This vulnerability is fixed in 6.12.0.
- CVSS 4.0
- 5.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 3.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L - EPSS
- 0.1% chance of exploitation in the next 30 days; higher than 2% of CVEs (scores of 2026-10-25)
- CWE
- CWE-834
- Published
- Modified
- Record from
- the NVD, synced
Affected
- pypdf_project:pypdf
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-248m-82v9-q6g6 | PyPI | pypdf | <6.12.0 | 6.12.0 |
| PYSEC-2026-3004 | PyPI | pypdf | <6.12.0 | 6.12.0 |