CVE-2026-48125
UAParser.js is a JavaScript library to detect browsers, operating systems, CPUs, and devices from user-agent data. From 2.0.1 until 2.0.10, a regular expression denial-of-service vulnerability exists when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause excessive CPU time due to catastrophic backtracking in the device regex because Client Hints values are copied without the UA_MAX_LENGTH limit used for User-Agent values. This issue is fixed in version 2.0.10.
- CVSS 3.1
- 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-400, CWE-1333
- Published
- Modified
- Record from
- the NVD, synced
Affected
- ua-parser-js_project:ua-parser-js
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9h5v-pfqq-x599 | npm | ua-parser-js | >=2.0.1 <2.0.10 | 2.0.10 |
References
- https://github.com/faisalman/ua-parser-js/commit/90354d3458495628b1d3ba68a9d76673e6d14fc5
- https://github.com/faisalman/ua-parser-js/releases/tag/2.0.10
- https://github.com/faisalman/ua-parser-js/security/advisories/GHSA-9h5v-pfqq-x599
- https://github.com/faisalman/ua-parser-js/security/advisories/GHSA-9h5v-pfqq-x599