cve.bz

CVE-2026-48069

7.5 highEPSS 0.9%

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

CVSS 3.1
7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 58% of CVEs (scores of 2026-10-25)
CWE
CWE-248
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js<1.9.161.9.16
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js>=1.10.0 <1.10.121.10.12
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js>=1.11.0 <1.11.41.11.4
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js>=1.12.0 <1.12.71.12.7
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js>=1.13.0 <1.13.51.13.5
GHSA-99f4-grh7-6pcqnpm@grpc/grpc-js>=1.14.0 <1.14.41.14.4

References

Check your stackJSON