CVE-2026-47762
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
- CVSS 3.1
- 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 20% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- tiny:tinymce
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-v98h-vmpc-fpqv | npm | tinymce | <=5.10.9 | no fix published |
| GHSA-v98h-vmpc-fpqv | npm | tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-v98h-vmpc-fpqv | npm | tinymce | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-v98h-vmpc-fpqv | NuGet | TinyMCE | <=5.10.9 | no fix published |
| GHSA-v98h-vmpc-fpqv | NuGet | TinyMCE | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-v98h-vmpc-fpqv | NuGet | TinyMCE | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-v98h-vmpc-fpqv | Packagist | tinymce/tinymce | <=5.10.9 | no fix published |
| GHSA-v98h-vmpc-fpqv | Packagist | tinymce/tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-v98h-vmpc-fpqv | Packagist | tinymce/tinymce | >=8.0.0 <8.5.1 | 8.5.1 |