CVE-2026-47759
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
- CVSS 3.1
- 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 20% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- tiny:tinymce
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-q742-qvgc-gc2f | npm | tinymce | <=5.10.9 | no fix published |
| GHSA-q742-qvgc-gc2f | npm | tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-q742-qvgc-gc2f | npm | tinymce | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-q742-qvgc-gc2f | NuGet | TinyMCE | <=5.10.9 | no fix published |
| GHSA-q742-qvgc-gc2f | NuGet | TinyMCE | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-q742-qvgc-gc2f | NuGet | TinyMCE | >=8.0.0 <8.5.1 | 8.5.1 |
| GHSA-q742-qvgc-gc2f | Packagist | tinymce/tinymce | <=5.10.9 | no fix published |
| GHSA-q742-qvgc-gc2f | Packagist | tinymce/tinymce | >=6.0.0 <7.9.3 | 7.9.3 |
| GHSA-q742-qvgc-gc2f | Packagist | tinymce/tinymce | >=8.0.0 <8.5.1 | 8.5.1 |