cve.bz

CVE-2026-46421

9.3 criticalEPSS 0.5%

Critical (9.3). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in @cap-js/sqlite 2.3.0.

The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.

Severity

CVSS 4.0

9.3 critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-506
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pvw4-cvr4-97p8npm@cap-js/sqlite>=2.2.2 <2.3.02.3.0
GHSA-pvw4-cvr4-97p8npm@cap-js/postgres>=2.2.2 <2.3.02.3.0
GHSA-pvw4-cvr4-97p8npm@cap-js/db-service>=2.10.1 <2.11.02.11.0

References

Check your stackJSON