CVE-2026-45772
Turborepo is a high-performance build system for JavaScript and TypeScript codebases. From 1.1.0 to before 2.9.14, Turborepo can be vulnerable to arbitrary code execution when run in untrusted repositories that contain malicious Yarn configuration. In affected versions, package manager detection executed yarn --version from the project directory, which could cause Yarn to load and execute a project-controlled yarnPath from .yarnrc.yml. An attacker who controls repository contents could cause code execution when a user or CI system runs affected turbo, @turbo/codemod, or @turbo/workspace conversion commands. This vulnerability is fixed in 2.9.14.
- CVSS 4.0
- 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-25)
- CWE
- CWE-426
- Published
- Modified
- Record from
- the NVD, synced
Affected
- vercel:turborepo
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-3qcw-2rhx-2726 | npm | turbo | >=1.1.0 <2.9.14 | 2.9.14 |
| GHSA-3qcw-2rhx-2726 | npm | @turbo/codemod | >=2.3.4 <2.9.14 | 2.9.14 |
| GHSA-3qcw-2rhx-2726 | npm | @turbo/workspaces | >=2.3.4 <2.9.14 | 2.9.14 |