cve.bz

CVE-2026-4539

1.9 lowEPSS 0.2%

Low (1.9). EPSS 0.2% chance of exploitation in the next 30 days. Fixed in pygments 2.20.0.

A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.

Severity

CVSS 4.0

1.9 low
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

CVSS 3.1

3.3 low
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
0.2% chance of exploitation in the next 30 days; higher than 5% of CVEs (scores of 2026-10-31)
CWEs
CWE-400, CWE-1333
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5239-wwwm-4pmqPyPIpygments<2.20.02.20.0
PYSEC-2026-2987PyPIpygments<2.20.02.20.0

References

Check your stackJSON