CVE-2026-45109
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-288, CWE-358
- Published
- Modified
- Record from
- the NVD, synced
Affected
- vercel:next.js
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-26hh-7cqf-hhc6 | npm | next | >=15.2.0 <15.5.18 | 15.5.18 |
| GHSA-26hh-7cqf-hhc6 | npm | next | >=16.0.0 <16.2.6 | 16.2.6 |