cve.bz

CVE-2026-44849

9.4 criticalEPSS 0.4%

Critical (9.4) in portainer portainer. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in github.com/portainer/portainer 2.33.8, 2.39.2, 2.41.0.

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

Severity

CVSS 4.0

9.4 critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWE
CWE-862
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5fxq-qcf3-244wGogithub.com/portainer/portainer>=2.33.0 <2.33.82.33.8
GHSA-5fxq-qcf3-244wGogithub.com/portainer/portainer>=2.39.0 <2.39.22.39.2
GHSA-5fxq-qcf3-244wGogithub.com/portainer/portainer>=2.40.0 <2.41.02.41.0
GO-2026-5143Gogithub.com/portainer/portainerall versionsno fix published

References

Check your stackJSON