CVE-2026-44616
LDAP injection vulnerability in Apache Zeppelin. ActiveDirectoryGroupRealm constructed LDAP search filters without escaping user-controlled input, allowing an authenticated attacker to inject LDAP filter syntax through the user-search endpoint and potentially expose directory information. The role-lookup path was also affected after successful LDAP authentication. This issue affects Apache Zeppelin versions 0.6.0 through 0.12.0. Users are recommended to upgrade to version 0.12.1, which fixes this issue.
- CVSS 3.1
- 6.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N - EPSS
- 0.8% chance of exploitation in the next 30 days; higher than 54% of CVEs (scores of 2026-10-25)
- CWE
- CWE-90
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:zeppelin