CVE-2026-44574
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
- CVSS 3.1
- 8.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N - EPSS
- 0.6% chance of exploitation in the next 30 days; higher than 50% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-288, CWE-551
- Published
- Modified
- Record from
- the NVD, synced
Affected
- vercel:next.js
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-492v-c6pp-mqqv | npm | next | >=15.4.0 <15.5.16 | 15.5.16 |
| GHSA-492v-c6pp-mqqv | npm | next | >=16.0.0 <16.2.5 | 16.2.5 |