CVE-2026-44282
Decidim is a participatory democracy framework. Prior to 0.32.0, a low-privilege process-scoped administrator or election editor with question-management rights can store HTML or script-bearing content in question.body. The question_title helper returns the translatable question body through html_safe without a sanitization boundary, causing stored script execution when visitors open public election pages or voting booth screens. The persisted script executes in visitors' browsers. The vulnerability is fixed in 0.32.0.
- CVSS 3.1
- 4.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-25)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9mvp-w4rr-5c6x | RubyGems | decidim-elections | <0.32.0 | 0.32.0 |
References
- https://github.com/decidim/decidim/commit/64dbea3739f360f1eb36932dfc49d9686e61fc00
- https://github.com/decidim/decidim/commit/b6e1b003365d10c0df2bc7edc5edd26b62fafda1
- https://github.com/decidim/decidim/pull/16659
- https://github.com/decidim/decidim/pull/16669
- https://github.com/decidim/decidim/releases/tag/v0.32.0