cve.bz

CVE-2026-44162

2.7 lowEPSS 0.5%

fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.

CVSS 3.1
2.7CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
EPSS
0.5% chance of exploitation in the next 30 days; higher than 41% of CVEs (scores of 2026-10-25)
CWE
CWE-409
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xv9w-7v6q-hpjhRubyGemsfluent-plugin-s3>=0.7.0 <1.8.51.8.5

References

Check your stackJSON