CVE-2026-43869
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
- CVSS 3.1
- 7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - EPSS
- 0.6% chance of exploitation in the next 30 days; higher than 50% of CVEs (scores of 2026-10-26)
- CWEs
- CWE-297, CWE-295
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:thrift
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-7pwc-h2j2-rjgj | Maven | org.apache.thrift:libthrift | <0.23.0 | 0.23.0 |