CVE-2026-43646
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 33% of CVEs (scores of 2026-10-26)
- CWE
- CWE-200
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:wicket
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-jvv4-8wxx-m5r6 | Maven | org.apache.wicket:wicket-parent | >=8.0.0-M1 <=8.17.0 | no fix published |
| GHSA-jvv4-8wxx-m5r6 | Maven | org.apache.wicket:wicket-parent | >=9.0.0-M1 <=9.22.0 | no fix published |
| GHSA-jvv4-8wxx-m5r6 | Maven | org.apache.wicket:wicket-parent | >=10.0.0-M1 <10.9.0 | 10.9.0 |