CVE-2026-43515
Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
- CVSS 3.1
- 9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N - EPSS
- 1.2% chance of exploitation in the next 30 days; higher than 68% of CVEs (scores of 2026-10-26)
- CWE
- CWE-285
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat.embed:tomcat-embed-core | <9.0.118 | 9.0.118 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=11.0.0-M1 <11.0.22 | 11.0.22 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat | <9.0.118 | 9.0.118 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat | >=11.0.0-M1 <11.0.22 | 11.0.22 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat-catalina | <9.0.118 | 9.0.118 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat-catalina | >=10.1.0-M1 <10.1.55 | 10.1.55 |
| GHSA-5m62-pw8w-7w9f | Maven | org.apache.tomcat:tomcat-catalina | >=11.0.0-M1 <11.0.22 | 11.0.22 |