cve.bz

CVE-2026-42797

4.9 mediumEPSS 0.4%

Medium (4.9) in apache syncope. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.apache.syncope.core:syncope-core-provisioning-api 4.0.6, 4.1.1.

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Severity

CVSS 3.1

4.9 medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 37% of CVEs (scores of 2026-10-31)
CWE
CWE-202
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vr35-jm2f-8wg2Mavenorg.apache.syncope.core:syncope-core-provisioning-api>=3.0.0-M0 <=3.0.16no fix published
GHSA-vr35-jm2f-8wg2Mavenorg.apache.syncope.core:syncope-core-provisioning-api>=4.0.0-M0 <4.0.64.0.6
GHSA-vr35-jm2f-8wg2Mavenorg.apache.syncope.core:syncope-core-provisioning-api>=4.1.0-M0 <4.1.14.1.1

References

Check your stackJSON