CVE-2026-42585
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 18% of CVEs (scores of 2026-10-25)
- CWE
- CWE-444
- Published
- Modified
- Record from
- the NVD, synced
Affected
- netty:netty
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-38f8-5428-x5cv | Maven | io.netty:netty-codec-http | >=4.2.0.Alpha1 <4.2.13.Final | 4.2.13.Final |
| GHSA-38f8-5428-x5cv | Maven | io.netty:netty-codec-http | <4.1.133.Final | 4.1.133.Final |