CVE-2026-42580
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's chunk size parser silently overflows int, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
- CVSS 3.1
- 6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 31% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-190, CWE-444
- Published
- Modified
- Record from
- the NVD, synced
Affected
- netty:netty
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-m4cv-j2px-7723 | Maven | io.netty:netty-codec-http | >=4.2.0.Alpha1 <4.2.13.Final | 4.2.13.Final |
| GHSA-m4cv-j2px-7723 | Maven | io.netty:netty-codec-http | <4.1.133.Final | 4.1.133.Final |