CVE-2026-42509
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
- CVSS 3.1
- 6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-26)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:wicket
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-5x9h-93gp-chpj | Maven | org.apache.wicket:wicket-parent | >=8.0.0-M1 <=8.17.0 | no fix published |
| GHSA-5x9h-93gp-chpj | Maven | org.apache.wicket:wicket-parent | >=9.0.0-M1 <=9.22.0 | no fix published |
| GHSA-5x9h-93gp-chpj | Maven | org.apache.wicket:wicket-parent | >=10.0.0-M1 <10.9.0 | 10.9.0 |