CVE-2026-42334
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 19% of CVEs (scores of 2026-10-25)
- CWE
- CWE-74
- Published
- Modified
- Record from
- the NVD, synced
Affected
- mongoosejs:mongoose
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-wpg9-53fq-2r8h | npm | mongoose | <6.13.9 | 6.13.9 |
| GHSA-wpg9-53fq-2r8h | npm | mongoose | >=7.0.0 <7.8.9 | 7.8.9 |
| GHSA-wpg9-53fq-2r8h | npm | mongoose | >=8.0.0 <8.22.1 | 8.22.1 |
| GHSA-wpg9-53fq-2r8h | npm | mongoose | >=9.0.0 <9.1.6 | 9.1.6 |