cve.bz

CVE-2026-42266

8.8 highEPSS 5.7%

High (8.8) in jupyter jupyterlab. EPSS 5.7% chance of exploitation in the next 30 days. Fixed in jupyterlab 4.5.7.

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
5.7% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWEs
CWE-88, CWE-602
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-37w4-hwhx-4rc4PyPIjupyterlab>=4.0.0 <4.5.74.5.7
PYSEC-2026-164PyPIjupyterlab>=4.0.0 <4.5.74.5.7

References

Check your stackJSON