cve.bz

CVE-2026-41677

1.7 lowEPSS 0.3%

Low (1.7) in rust-openssl project rust-openssl. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in openssl 0.10.78.

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

Severity

CVSS 4.0

1.7 low
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 22% of CVEs (scores of 2026-10-31)
CWEs
CWE-125, CWE-1284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xmgf-hq76-4vx2crates.ioopenssl>=0.9.0 <0.10.780.10.78

References

Check your stackJSON