CVE-2026-41643
GoBGP is an open source Border Gateway Protocol (BGP) implementation in the Go Programming Language. Prior to version 4.3.0, a remote Denial of Service (DoS) vulnerability exists in GoBGP where a malformed BGP UPDATE message can trigger a runtime error: index out of range panic. This occurs during the processing of 4-byte AS attributes when the message structure causes an internal slice index shift that is not properly handled. This issue has been patched in version 4.3.0.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-26)
- CWE
- CWE-129
- Published
- Modified
- Record from
- the NVD, synced
Affected
- osrg:gobgp
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-8rxh-r2p6-7f2q | Go | github.com/osrg/gobgp/v4 | <4.3.0 | 4.3.0 |
| GO-2026-5266 | Go | github.com/osrg/gobgp/v4 | <4.3.0 | 4.3.0 |