CVE-2026-41636
Uncontrolled Recursion vulnerability in Apache Thrift Node.js bindings This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
- CVSS 4.0
- 8.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L - CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-26)
- CWE
- CWE-674
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:thrift
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-r67j-r569-jrwp | npm | thrift | <0.23.0 | 0.23.0 |