CVE-2026-41608
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 1.0% chance of exploitation in the next 30 days; higher than 63% of CVEs (scores of 2026-10-25)
- CWE
- CWE-409
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:thrift
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-6pjx-3pjc-mrj8 | PyPI | thrift | <0.24.0 | 0.24.0 |
| PYSEC-2026-3925 | PyPI | thrift | <0.24.0 | 0.24.0 |