CVE-2026-41140
Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.
- CVSS 4.0
- 0.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U - CVSS 3.1
- 8.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:H - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 21% of CVEs (scores of 2026-10-26)
- CWE
- CWE-22
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-73h3-mf4w-8647 | PyPI | poetry | <2.3.4 | 2.3.4 |
| PYSEC-2026-2890 | PyPI | poetry | <2.3.4 | 2.3.4 |
References
- https://github.com/python-poetry/poetry/security/advisories/GHSA-73h3-mf4w-8647
- https://access.redhat.com/errata/RHSA-2026:24866
- https://access.redhat.com/security/cve/CVE-2026-41140
- https://bugzilla.redhat.com/show_bug.cgi?id=2461604
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41140.json