CVE-2026-40347
Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.
- CVSS 3.1
- 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 28% of CVEs (scores of 2026-10-26)
- CWEs
- CWE-400, CWE-834
- Published
- Modified
- Record from
- the NVD, synced
Affected
- fastapiexpert:python-multipart
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-mj87-hwqh-73pj | PyPI | python-multipart | <0.0.26 | 0.0.26 |
| PYSEC-2026-3038 | PyPI | python-multipart | <0.0.26 | 0.0.26 |