cve.bz

CVE-2026-40155

5.4 mediumEPSS 0.2%

Medium (5.4) in auth0 nextjs-auth0. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in @auth0/nextjs-auth0 4.18.0.

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS
0.2% chance of exploitation in the next 30 days; higher than 11% of CVEs (scores of 2026-10-31)
CWEs
CWE-362, CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xq8m-7c5p-c2r6npm@auth0/nextjs-auth0>=4.12.0 <4.18.04.18.0

References

Check your stackJSON