cve.bz

CVE-2026-34756

6.5 mediumEPSS 0.4%

Medium (6.5) in vllm vllm. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in vllm 0.19.0.

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 36% of CVEs (scores of 2026-10-31)
CWEs
CWE-770, CWE-1284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3mwp-wvh9-7528PyPIvllm>=0.1.0 <0.19.00.19.0
PYSEC-2026-2298PyPIvllm>=0.1.0 <0.19.00.19.0

References

Check your stackJSON