cve.bz

CVE-2026-34487

7.5 highEPSS 0.4%

Insertion of Sensitive Information into Log File vulnerability in the cloud membership for clustering component of Apache Tomcat exposed the Kubernetes bearer token. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.13 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.

CVSS 3.1
7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-26)
CWE
CWE-532
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat-tribes>=9.0.13 <9.0.1179.0.117
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat-tribes>=10.1.0-M1 <10.1.5410.1.54
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat-tribes>=11.0.0-M1 <11.0.2111.0.21
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat>=9.0.13 <9.0.1179.0.117
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat>=10.1.0-M1 <10.1.5410.1.54
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat:tomcat>=11.0.0-M1 <11.0.2111.0.21
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.13 <9.0.1179.0.117
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.0-M1 <10.1.5410.1.54
GHSA-x4m4-345f-5h5gMavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.0-M1 <11.0.2111.0.21

References

Check your stackJSON