CVE-2026-34486
Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor. This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 99% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-26)
- CISA KEV
- listed 2026-08-04, due 2026-08-07
- CWEs
- CWE-311, CWE-807
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
- redhat:enterprise_linux
- redhat:enterprise_linux_els
- redhat:enterprise_linux_eus
- redhat:enterprise_linux_tus
- redhat:enterprise_linux_update_services_for_sap_solutions
- redhat:jboss_web_server
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat-tribes | >=11.0.20 <11.0.21 | 11.0.21 |
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat-tribes | >=10.1.53 <10.1.54 | 10.1.54 |
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat-tribes | >=9.0.116 <9.0.117 | 9.0.117 |
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat | >=11.0.20 <11.0.21 | 11.0.21 |
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat | >=10.1.53 <10.1.54 | 10.1.54 |
| GHSA-69r9-qgr7-g2wj | Maven | org.apache.tomcat:tomcat | >=9.0.116 <9.0.117 | 9.0.117 |
References
- https://lists.apache.org/thread/9510k5p5zdvt9pkkgtyp85mvwxo2qrly
- https://www.vicarius.io/vsociety/posts/cve-2026-34486-detection-script-rce-on-apache-tomcat
- https://www.vicarius.io/vsociety/posts/cve-2026-34486-mitigation-script-rce-on-apache-tomcat
- https://access.redhat.com/errata/RHSA-2026:36787
- https://access.redhat.com/errata/RHSA-2026:36788