CVE-2026-34483
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-26)
- CWE
- CWE-116
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat-catalina | >=9.0.40 <9.0.116 | 9.0.116 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat-catalina | >=10.1.0-M1 <10.1.54 | 10.1.54 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat-catalina | >=11.0.0-M1 <11.0.21 | 11.0.21 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat | >=9.0.40 <9.0.116 | 9.0.116 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat | >=10.1.0-M1 <10.1.54 | 10.1.54 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat:tomcat | >=11.0.0-M1 <11.0.21 | 11.0.21 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=9.0.40 <9.0.116 | 9.0.116 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=10.1.0-M1 <10.1.54 | 10.1.54 |
| GHSA-rv64-5gf8-9qq8 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=11.0.0-M1 <11.0.21 | 11.0.21 |