cve.bz

CVE-2026-33997

8.1 highEPSS 0.4%

High (8.1) in docker engine. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in github.com/moby/moby/v2 2.0.0-beta.8.

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 34% of CVEs (scores of 2026-10-31)
CWEs
CWE-193, CWE-266
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pxq6-2prw-chj9Gogithub.com/docker/dockerall versionsno fix published
GHSA-pxq6-2prw-chj9Gogithub.com/moby/moby/v2<2.0.0-beta.82.0.0-beta.8
GHSA-pxq6-2prw-chj9Gogithub.com/moby/mobyall versionsno fix published
GO-2026-4883Gogithub.com/docker/dockerall versionsno fix published
GO-2026-4883Gogithub.com/moby/mobyall versionsno fix published
GO-2026-4883Gogithub.com/moby/moby/v2<2.0.0-beta.82.0.0-beta.8

References

Check your stackJSON