cve.bz

CVE-2026-33409

7.0 highEPSS 0.5%

High (7.0) in parseplatform parse-server. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in parse-server 8.6.52, 9.6.0-alpha.41.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

Severity

CVSS 4.0

7.0 high
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pfj7-wv7c-22prnpmparse-server>=9.0.0 <9.6.0-alpha.419.6.0-alpha.41
GHSA-pfj7-wv7c-22prnpmparse-server<8.6.528.6.52

References

Check your stackJSON