cve.bz

CVE-2026-33229

8.6 highEPSS 0.5%

High (8.6) in xwiki xwiki. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in org.xwiki.platform:xwiki-platform-oldcore 17.10.1, 17.4.8.

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.

Severity

CVSS 4.0

8.6 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-862
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h259-74h5-4rh9Mavenorg.xwiki.platform:xwiki-platform-oldcore>=17.0.0-rc-1 <17.4.817.4.8
GHSA-h259-74h5-4rh9Mavenorg.xwiki.platform:xwiki-platform-oldcore>=17.5.0-rc-1 <17.10.117.10.1
GHSA-h259-74h5-4rh9Mavenorg.xwiki.platform:xwiki-platform-legacy-oldcore>=17.0.0-rc-1 <17.4.817.4.8
GHSA-h259-74h5-4rh9Mavenorg.xwiki.platform:xwiki-platform-legacy-oldcore>=17.5.0-rc-1 <17.10.117.10.1

References

Check your stackJSON