CVE-2026-32990
Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.
- CVSS 3.1
- 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 23% of CVEs (scores of 2026-10-26)
- CWE
- CWE-20
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat-coyote | >=9.0.113 <9.0.116 | 9.0.116 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat-coyote | >=10.1.50 <10.1.53 | 10.1.53 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat-coyote | >=11.0.15 <11.0.20 | 11.0.20 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat | >=9.0.113 <9.0.116 | 9.0.116 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat | >=10.1.50 <10.1.53 | 10.1.53 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat:tomcat | >=11.0.15 <11.0.20 | 11.0.20 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=9.0.113 <9.0.116 | 9.0.116 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=10.1.50 <10.1.53 | 10.1.53 |
| GHSA-8mc5-53m5-3qj2 | Maven | org.apache.tomcat.embed:tomcat-embed-core | >=11.0.15 <11.0.20 | 11.0.20 |