cve.bz

CVE-2026-31872

8.7 highEPSS 0.4%

High (8.7) in parseplatform parse-server. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in parse-server 8.6.32, 9.6.0-alpha.6.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.

Severity

CVSS 4.0

8.7 high
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-31)
CWE
CWE-284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r2m8-pxm9-9c4gnpmparse-server>=9.0.0-alpha.1 <9.6.0-alpha.69.6.0-alpha.6
GHSA-r2m8-pxm9-9c4gnpmparse-server<8.6.328.6.32

References

Check your stackJSON