cve.bz

CVE-2026-31841

6.5 mediumEPSS 0.2%

Medium (6.5) in hyperterse hyperterse. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in hyperterse 2.2.0.

Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
0.2% chance of exploitation in the next 30 days; higher than 8% of CVEs (scores of 2026-10-31)
CWE
CWE-433
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-92gp-jfgx-9qpvnpmhyperterse>=2.0.0 <2.2.02.2.0

References

Check your stackJSON