cve.bz

CVE-2026-31828

6.0 mediumEPSS 0.4%

Medium (6.0) in parseplatform parse-server. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in parse-server 8.6.26, 9.5.2-alpha.13.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.

Severity

CVSS 4.0

6.0 medium
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 39% of CVEs (scores of 2026-10-31)
CWE
CWE-90
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7m6r-fhh7-r47cnpmparse-server>=9.0.0-alpha.1 <9.5.2-alpha.139.5.2-alpha.13
GHSA-7m6r-fhh7-r47cnpmparse-server<8.6.268.6.26

References

Check your stackJSON