CVE-2026-30912
In case of SQL errors, exception/stack trace of errors was exposed in API even if "api/expose_stack_traces" was set to false. That could lead to exposing additional information to potential attacker. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 38% of CVEs (scores of 2026-10-26)
- CWE
- CWE-668
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:airflow
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-w7cf-2pmc-5m4c | PyPI | apache-airflow-core | <3.2.0 | 3.2.0 |
| PYSEC-2026-18 | PyPI | apache-airflow | <3.2.0 | 3.2.0 |
| PYSEC-2026-2361 | PyPI | apache-airflow-core | <3.2.0 | 3.2.0 |