CVE-2026-29146
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
- CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 8.8% chance of exploitation in the next 30 days; higher than 95% of CVEs (scores of 2026-10-26)
- CWEs
- CWE-209, CWE-642, CWE-1240
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:tomcat
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat-tribes | >=9.0.13 <9.0.116 | 9.0.116 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat-tribes | >=10.1.50 <10.1.53 | 10.1.53 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat-tribes | >=11.0.0-M1 <11.0.20 | 11.0.20 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat | >=9.0.13 <9.0.116 | 9.0.116 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat | >=10.1.50 <10.1.53 | 10.1.53 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat | >=11.0.0-M1 <11.0.20 | 11.0.20 |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat-tribes | >=8.5.38 <=8.5.100 | no fix published |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat | >=8.5.38 <=8.5.100 | no fix published |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat-tribes | >=7.0.100 <=7.0.109 | no fix published |
| GHSA-h468-7pvh-8vr8 | Maven | org.apache.tomcat:tomcat | >=7.0.100 <=7.0.109 | no fix published |