cve.bz

CVE-2026-29129

7.5 highEPSS 0.3%

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

CVSS 3.1
7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 17% of CVEs (scores of 2026-10-26)
CWE
CWE-327
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat-coyote>=9.0.114 <9.0.1169.0.116
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat-coyote>=10.1.51 <10.1.5310.1.53
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat-coyote>=11.0.16 <11.0.2011.0.20
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat>=9.0.114 <9.0.1169.0.116
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat>=10.1.51 <10.1.5310.1.53
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat:tomcat>=11.0.16 <11.0.2011.0.20
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.114 <9.0.1169.0.116
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.51 <10.1.5310.1.53
GHSA-69cc-cv78-qc8gMavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.16 <11.0.2011.0.20

References

Check your stackJSON