cve.bz

CVE-2026-27971

9.2 criticalEPSS 5.5%

Critical (9.2) in qwik qwik. EPSS 5.5% chance of exploitation in the next 30 days. Fixed in @builder.io/qwik 1.19.1.

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

Severity

CVSS 4.0

9.2 critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
5.5% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p9x5-jp3h-96mmnpm@builder.io/qwik<1.19.11.19.1

References

Check your stackJSON