cve.bz

CVE-2026-27893

8.8 highEPSS 1.4%

High (8.8) in vllm vllm. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in vllm 0.18.0.

vLLM is an inference and serving engine for large language models (LLMs). Starting in version 0.10.1 and prior to version 0.18.0, two model implementation files hardcode `trust_remote_code=True` when loading sub-components, bypassing the user's explicit `--trust-remote-code=False` security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust. Version 0.18.0 patches the issue.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
1.4% chance of exploitation in the next 30 days; higher than 71% of CVEs (scores of 2026-10-31)
CWEs
CWE-693, CWE-501
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7972-pg2x-xr59PyPIvllm>=0.10.1 <0.18.00.18.0
PYSEC-2026-2297PyPIvllm>=0.10.1 <0.18.00.18.0

References

Check your stackJSON