cve.bz

CVE-2026-2742

5.3 mediumEPSS 0.4%

Medium (5.3) in vaadin vaadin. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in com.vaadin:flow-server 14.14.1, 23.6.7, 24.9.8.

An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0 through 25.0.1, applications using Spring Security due to inconsistent path pattern matching of reserved framework paths. Accessing the /VAADIN endpoint without a trailing slash bypasses security filters, and allowing unauthenticated users to trigger framework initialization and create sessions without proper authorization. Users of affected versions using Spring Security should upgrade as follows: 14.0.0-14.14.0 upgrade to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0 - 24.9.7 to 24.9.8, and 25.0.0-25.0.1 upgrade to 25.0.2 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

Severity

CVSS 4.0

5.3 medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/S:N/AU:Y/R:A/V:D/RE:L/U:Amber

CVSS 3.1

5.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 34% of CVEs (scores of 2026-10-31)
CWE
CWE-284
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rjgh-wgc7-m37jMavencom.vaadin:flow-server<14.14.114.14.1
GHSA-rjgh-wgc7-m37jMavencom.vaadin:flow-server>=23.0.0 <23.6.723.6.7
GHSA-rjgh-wgc7-m37jMavencom.vaadin:flow-server>=24.0.0 <24.9.824.9.8
GHSA-rjgh-wgc7-m37jMavencom.vaadin:flow-server>=25.0.0 <25.0.225.0.2
GHSA-rjgh-wgc7-m37jMavencom.vaadin:vaadin>=25.0.0 <25.0.225.0.2
GHSA-rjgh-wgc7-m37jMavencom.vaadin:vaadin>=24.0.0 <24.9.824.9.8
GHSA-rjgh-wgc7-m37jMavencom.vaadin:vaadin>=23.0.0 <23.6.723.6.7
GHSA-rjgh-wgc7-m37jMavencom.vaadin:vaadin<14.14.114.14.1

References

Check your stackJSON