cve.bz

CVE-2026-2741

2.3 lowEPSS 0.4%

Low (2.3) in vaadin vaadin. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in com.vaadin:flow-project 14.14.1, 23.6.7, 24.9.9.

Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 15.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2. Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory. Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 15.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

Severity

CVSS 4.0

2.3 low
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/AU:N/R:U/V:D/RE:L/U:Amber

CVSS 3.1

6.8 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8jrh-7jg8-fvmvMavencom.vaadin:flow-project>=14.2.0 <14.14.114.14.1
GHSA-8jrh-7jg8-fvmvMavencom.vaadin:flow-project>=23.0.0 <23.6.723.6.7
GHSA-8jrh-7jg8-fvmvMavencom.vaadin:flow-project>=24.0.0 <24.9.924.9.9
GHSA-8jrh-7jg8-fvmvMavencom.vaadin:flow-project>=25.0.0 <25.0.325.0.3

References

Check your stackJSON