cve.bz

CVE-2026-26974

7.6 highEPSS 0.6%

High (7.6) in slyde.js slyde. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in @tygo-van-den-hurk/slyde 0.0.5.

Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

Severity

CVSS 4.0

7.6 high
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 49% of CVEs (scores of 2026-10-31)
CWE
CWE-829
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w7h5-55jg-cq2fnpm@tygo-van-den-hurk/slyde<0.0.50.0.5

References

Check your stackJSON